Team select blank page

Incident Report for Florence Healthcare Status Page

Monitoring

We have identified that the root cause is related to browser caching. We are currently monitoring the situation. If users continue to experience a blank screen after logging in they need to perform a hard refresh. To do this, while on the blank screen, press CMD + SHIFT + R on Mac or CTRL + SHIFT + R on PC.
Posted Mar 21, 2025 - 11:47 EDT

Identified

The issue has been identified.
Posted Mar 19, 2025 - 11:09 EDT

Update

We are continuing to investigate this issue.
Posted Mar 19, 2025 - 11:08 EDT

Investigating

Intermittent issues with accessing eBinders teams. We are investigating the issue.
Posted Mar 19, 2025 - 10:26 EDT
This incident affects: eBinders (eBinder).