Document Preview Issue

Incident Report for Florence Healthcare Status Page

Resolved

Patch fix 92.0.4. was deployed to eBinders and the issue has now been resolved.
Posted Apr 28, 2026 - 09:28 EDT

Investigating

We are currently investigating reports of incidental issues with document preview functionality. Users may see error messages when attempting to open certain documents. As a temporary workaround, customers can download and re-upload their documents to restore access. Our team is actively working to resolve this issue as quickly as possible and will provide updates as they become available.
Posted Apr 27, 2026 - 17:12 EDT
This incident affected: eBinders (eBinder).