eBinders Document Download Issues

Incident Report for Florence Healthcare Status Page

Resolved

The eBinders performance issues have been resolved. The document download functionality has been restored and all services are now operating normally.
Posted Dec 16, 2025 - 14:52 EST

Identified

We are currently investigating reports of degraded system performance affecting document download capabilities. Users may experience delays when downloading documents.
Posted Dec 16, 2025 - 12:37 EST
This incident affected: eBinders (Document Download).